Xmanager Forum

very slow using Java GUI

Last post: Friday, November 28, 2003 5:02 PM by Bill, 3 reply

 
Tuesday, November 25, 2003 8:05 PM - zhaojingqian

very slow using Java GUI

 
With my hp server ,I use to make an export DISLAY using xmanager for a Motif application and
the performance was good.

I am now trying to run Java application(oracle installer) using xwin32, and the performance
are awful. I did already optimize the xmanager conf, but it is still very
slow.

Did someone already meet this problem ? Why Java decrease the performance
?
Any solution, fix ???
Wednesday, November 26, 2003 6:14 PM - H. M. Kim

Re: very slow using Java GUI

 
The problem may be caused when the java requires a lot of big fonts such as Korean or Chinese characters. Try to run the Oracle Installer with English.

First, run an xterm or dtterm using Xstart, change the locale to "C" as following:

$ export LANG=C

And then run Oracle Installer at the prompt of xterm.

Kim
Thursday, November 27, 2003 1:57 PM - zhaojingqian

Re: Re: very slow using Java GUI

 
i really use the english to install oracle,but the speed is slow.first time i think the problem is with jave gui ,but after install ibm websphere 5.0,
i changed my mind. because the websphere installer is much quick compared with oracle installer. and i find another amazing thing: if the gui have a picture,it's show up slow .so i think the problem is with the jave showing picture. how to overcome this ,i have no idea.
Friday, November 28, 2003 5:02 PM - Bill

Re: Re: Re: very slow using Java GUI

 
How about your network bandwidth? If the network line is a LAN, there should be no such delay.