Xmanager Forum

xmanager behind NAT on Windows XP

Last post: Wednesday, November 19, 2003 6:13 PM by Support, 4 reply

 
Monday, November 17, 2003 11:55 PM - Mike

xmanager behind NAT on Windows XP

 
Hi,

I have a problem with the configuration of xmanager under Windows XP. My computer is connected to internet via an ADSL-router (Thomson Speedtouch 510).

I cannot connect to a UNIX machine by using the REXEC protocol.
In the NAPT option of the router, I have forwarded the tcp port 6001 of my router to the port 6000 of my computer. In xstart, I use the command line
/usr/bin/X11/xterm -ls -display 10.0.0.39:1
where 10.0.0.39 is the local address of my computer. Each time I try to connect I get the error message:

Cannot connect to the remote host. Please make sure if the host is ready.

I can connect to the UNIX machine with a telnet program (not xmanager). I cannot use the SSH protocol as it is not accepted by the UNIX machine.

Can you help me ?

Thanks,

Mike
Tuesday, November 18, 2003 8:30 AM - Support

Re: xmanager behind NAT on Windows XP

 
Please select the TELNET protocol in Xstart. It seems that your Unix server doesn't support REXEC protocol.

----
Technical Support
Tuesday, November 18, 2003 9:11 AM - Zookeyan

Re: xmanager behind NAT on Windows XP

 
And you should set DISPLAY as router's ip address and port in the command line.

/usr/bin/X11/xterm -ls -display ROUTER_IP_ADDR:1
Wednesday, November 19, 2003 5:13 AM - Mike

Re: xmanager behind NAT on Windows XP

 
Hi,

I know the Unix system accept the rexec protocol because I used it before when I was connecting via a 56K modem.

What IP address do I have to use with "-display" in the command line with the rexec protocol ?
The IP address of my router is dynamic, and change at each connection. How can I determine that address ?

Thanks for the help,

Mike
Wednesday, November 19, 2003 6:13 PM - Support

Re: Re: xmanager behind NAT on Windows XP

 
If your router gets a dynamic IP address, you can use REMOTEHOST variable like this:
  /usr/bin/X11/xterm -ls -display $REMOTEHOST:1
The REMOTEHOST environment option is available in Linux servers. If your Unix doesn't support it, you can add the following lines to your login script:
  REMOTEHOST=`who am i | sed -n 's/.*(\([^) ]*\).*/\1/p; 1q'`
  export REMOTEHOST
For csh-like shells, do the following:
  setenv REMOTEHOST `who am i | sed -n 's/.*(\([^) ]*\).*/\1/p; 1q'`

In addition, select TELNET protocol in Xstart.

Hope to solve the problem.

----
Technical Support