Xmanager Forum

Arrow keypad not working with Num Lock set

Last post: Saturday, November 15, 2003 5:10 AM by Support, 8 reply

 
Wednesday, November 12, 2003 4:21 PM - Tom

Arrow keypad not working with Num Lock set

 
Help

I have not been able to resolve my problem with the arrow key mapping with Num Lock set.

I am using Windows XP Pro with a Us 1012B for-key compatible keyboard. It is actually a micro innovations KB901 and windows is using the standard 101/102-Key driver.

I have tried multiple versions of Xmanager 1.3.9. This used to work fine but now it does not. I do not know if it broke with a keyboard change (don't believe so), XP upgrade, or Xmanager upgrade???

Problem is when numlock not active, arrow keys work fine, when numlock active, no joy. If using an xterm the display shows a 2A for up, 2B for down, 2C for right and a 2D for left as well as a beep. If using the xmanager keyboard editor, when pressing any of the arrow keys while the numlock is set, while the key is pressed you get the arrow key scancode, when released it changes to the left shift key. Indications are that the keyboard (or something) is sending a dual scancode for the arrow keys when numlock is active. I can clear all keymapping for the arrow keys and the xwindow ignores the keypressings, so it appears to definitely be a windows/xmanager related problem.

Any help would be greatly appreciated.

Thanks,
Tom
Wednesday, November 12, 2003 10:58 PM - Support

Re: Arrow keypad not working with Num Lock set

 
Please try to change the terminal type of xterm as following:

For csh:
$ setenv TERM ansi

For sh or bash:
$ export TERM=ansi

If it doesn't solve the problem, try to test the arrow keys in the Windows Notepad program. Also try another keyboard in your office.

If the problem persists, please let us know the following:

- Detailed Windows version (with service pack).
- The model name of your keyboard.
- Keyboard driver and input locale. You can find the information from Control Panel.

----
Technical Support
Thursday, November 13, 2003 7:47 AM - Tom

Re: Re: Arrow keypad not working with Num Lock set

 
Thanks for the quick reply.

Setting TERM type has no effect. This is not a linux configuration issue.

Arrow keys are fully functional in all other applications, I only have this problem in xmanager.

I booted the computer in question into linux (Mandrake 9.1) and it works fine, both with numlock set and cleared.

Windows configuration:

Windows Version

Microsoft XP Professional, version 2002 with service pack 1

Keyboard in a micro-innovations KB900i
Keyboard driver Standard 101/102-key or Microsoft Natural PS/2 Keyboard. I also tried the PC/AT Enhanced PS/2 Keyboard (101/102-key). Keyboard is plugged into the standard Motherboard PS/2 keyboard connector.

Using the X11R6-contrib package file xev, I captured key-press detain in both a native gnome-terminal window running in linux on suspect system as well as the same keystrokes from a gnome-terminal window from xmanager. The results are included in the two included data files. The file capture-linux.txt is the data captured from the native linux session, and the file capture-xmanager is from the windows session running xmanager.

This problem is there in gnome-terminal, eterm, xterm, and kconsole. I haven't tried any futher xterm compliant packages, as it does not appear to be linux related as can be seen from the xev capture settings.

If you have not heard of this problem with other users running xmanager under win XP pro, then I will assume it is a configuration problem on my box and not related to xmanager.

If you have any further suggestions, I would be very appreciative.

Tom
Friday, November 14, 2003 3:04 AM - Support

Re: Re: Re: Arrow keypad not working with Num Lock set

 
We are not able to reproduce the same problem in our systems. It seems that your keyboard generates Shift key events when the NumLock key is on.

Attached please find a keylook program that catches all keyboard events for your keyboard. After pressing the NumLock key, press the arrow keys, and then save the logs in a file. Please upload the results for further support.

Thanks for your cooperation.

----
Technical Support
Attachment keylook.exe (40 KB)  
Friday, November 14, 2003 2:52 PM - Tom

Re: Re: Re: Re: Arrow keypad not working with Num Lock set

 
Thanks for continuing to look into this matter. attached you will find the file with the keylook results requested. I started with numlock not active, depressed numlock then Up, Right, Down, and Left then saved the file.

I do not believe it is a keyboard issue as the xev results I provided shows, the keyboard does not generate the extra scancodes under native linux, just from my Windows session.

Since you cannot reproduce the problem, it looks like I have a helper application buried somewhere in my windows system that is causing the extra scancodes. I will concentrate my efforts there.

Since you have been trying to identify the problem, I will be sure to include any results I find in case you get another user with the same problem.

As always, I appreciate any help you are able to provide, but it does not appear to be a xmanager problem.

Sincerely,
Tom
Friday, November 14, 2003 3:15 PM - Support

Re: Re: Re: Re: Re: Arrow keypad not working with Num Lock set

 
According to the results of keylook program, your keyboard generates extra key events (virtual key code: 255, scancode 42) when you press arrow keys. The scancode 42 is for the Shift_L key. The normal Shift_L key generates a key event as following:

Virtual Key: 16 (VK_SHIFT)
Scancode: 42

I think your keyboard driver generates meaningless WM_KEYDOWN events when the NumLock key is active.

Xmanager can be modified to consider this problem, but we would like to know what causes such a problem. It may be due to your keyboard driver, or else another application in your Windows.

If you have another PC in your office, please try Xmanager in that one.

Any hints would be greatly appreciated.

----
Technical Support
Friday, November 14, 2003 4:12 PM - Tom

Re: Re: Re: Re: Re: Re: Arrow keypad not working with Num Lock set

 
Thanks for help. You have come to the same conclusion that I have. It is definitely something in the windows environment as the exact same computer and keyboard works fine when booting into linux.

This problem did not exist on this computer in the past, however since I have done losts of different things to this machine over the last year or so, I do not know which event induced the problem.

If I find out what it is I will leave a new reply to this chain.

Thanks for the investigation.
Friday, November 14, 2003 4:45 PM - Tom

Re: Re: Re: Re: Re: Re: Re: Arrow keypad not working with Num Lock set

 
Located the general source of the problem!!

I have an ATI All-In-Wonder Radeon video card running the Catalyst Driver set associated with Driver version 6.14.10.6343.

One of the system files associated with this driver file set is causing the problems. If I go to the Task manager and terminal the ati... applications running the problem goes away. They do not affect the general running of the computer, rather I believe they are some of the extra feature stuff (don't know without further investigation)

Anyway, when I kill the ancilliary applications for the ati card, problem is gone.

Thanks for the help, and sorry to have bothered you for a problem you did not cause.

Sincerely,
Tom
Saturday, November 15, 2003 5:10 AM - Support

Re: Re: Re: Re: Re: Re: Re: Re: Arrow keypad not working with Num Lock set

 
Thanks for your information.
Your feedback will be helpful for our future service.

---
Technical Support