Xmanager Forum

Redhat Linux 9.0 theme window fails to show

Last post: Tuesday, October 14, 2003 6:12 PM by Support, 4 reply

 
Friday, October 10, 2003 12:40 AM - Daniel

Redhat Linux 9.0 theme window fails to show

 
I can log into Redhat 9.0 on my computer and everthing works fine. I do have some x windows that won't show up though. Mozilla, Nautilus, terminal windows, process manager, all show up but if I try to use the gnome-theme-manager it will show on the Window List of as starting. It will then fail to produce the Theme window but the gnome-theme-manager process will still be running. I can do the same thing on an NCD thin clint terminal and it works fine. I also tried an evaluation version of X-win32 and it works fine and doesn't have the problem.

--------------
Attached is the Xmanager.log and the .xsession-errors file
Friday, October 10, 2003 12:54 AM - Support

Re: Redhat Linux 9.0 theme window fails to show

 
First of all, please try to upgrade Xmanager to the newest version 1.3.9.8 build 9:

/download/download.html

It fixes some problems in Windows TCP/IP.

And we will test the theme manager and reply to you soon.

----
Technical Support
Friday, October 10, 2003 1:08 AM - Daniel

Re: Re: Redhat Linux 9.0 theme window fails to show

 
I did the up date and still have the same problem.
Friday, October 10, 2003 2:26 PM - Support

Re: Re: Re: Redhat Linux 9.0 theme window fails to show

 
We tried the theme manager and it work when Xmanager is configured to 256-color mode. You can do it as following:

1. Run Xconfig in the Xmanager folder.
2. Click Color tab.
3. In the Default Visual list box, select PseudoColor.
4. Save the change and restart Xmanager.

For true color video, we need to test it further. We will reply to this article as soon as a solution is found.

----
Technical Support
Tuesday, October 14, 2003 6:12 PM - Support

Re: Re: Re: Redhat Linux 9.0 theme window fails to show

 
We found a solution for the theme manager problem. The program requires a fixed color specification for the true color visual.

To fix it, please do the following:

1. Open the "C:\Program Files\Xmanager1.3.9\Xmanager.ini" file with Notepad.
2. Go to the [Options] section.
3. Add "RGBOrder" value as following:
[Options]
RGBOrder=1
4. Save it and restart Xmanager.

Now, you can use the theme manager in the TrueColor visual.

----
Technical Support