Xmanager Forum

Error connecting to Font Server

Last post: Thursday, August 7, 2003 4:04 PM by Colin, 2 reply

 
Thursday, August 7, 2003 12:30 PM - Colin

Error connecting to Font Server

 
I am having a problem connecting to a font server residing on a Red Hat 9 server.

A little background: I can make a connection to the server just fine using the default set of fonts as well as the Euro pack. One of the applications I am running on the server, built using wxPython comes up with strange monospaced fonts.

To resolve this we decided to use the xfs server on the Red Hat machine as the font server for Xmanager. Upon attempting to connect we get the error "could not open default font 'fixed' and Xmanager exits. We eliminated lines in /etc/X11/fs/config and continued trying to connect until finally we were left with Type1 and Speedo fonts when a connection was made. Unfortunately the app still had the strange fonts.

I know that this can be resolved as we attempted connecting with another well-know (incredibly expensive) X client using the RH9 server's xfs as the font server and it worked fine, fonts showing up as they are meant to.

Have you come across this issue anyone?

Again, the error we're getting when using the xfs server is "could not open default font 'fixed'. Nothing but that in the log as well.

Specs:
Server: Red Hat 9
Display Manager: GDM
Font Server: xfs
Xmanager: 1.3.9 with Euro fonts installed
Client OS: Windows 2000 and XP

Any help greatly appreciated.
Thursday, August 7, 2003 1:21 PM - Support

Re: Error connecting to Font Server

 
The problem might occur when the font server is on top of other font directories in the Xconfig.

Please try to move up the "misc" font on top of the font server you added.

----
Technical Support
Thursday, August 7, 2003 4:04 PM - Colin

Re: Re: Error connecting to Font Server

 
That did it. Thank you very much.

I have it set up with Misc on top in the ordering, and the font server immediately underneath.

Again, thanks for your help. Xmanager is a great product.